Skip to main content
IMPORTANT NOTICE: Start your education with Northeastern Illinois University! Space is still available for Fall 2018. Apply now! More information »

Operating Systems and Browsers that Support TLS v.1.1+

You are here

Operating Systems and Browsers That Support TLS v.1.1+

Compatible Operating Systems Required

  • Windows® 7
  • Windows 8
  • Windows 8.1
  • Windows 10
  • Windows Server 2008 R2
  • Windows Server 2012

Compatible Browsers Required

  • Chrome® v.22+
  • Firefox® version v.27+
  • Internet Explorer® v.8-10 (if enabled)
  • Internet Explorer v.11
  • Safari® v.7+
  • Edge®
Back to Top